» NSIS-vvvv-Installer
This site relies heavily on Javascript. You should enable it if you want the full experience. Learn more.

NSIS-vvvv-Installer

tool installer
Credits: NSIS-Installer

about

We managed to write a small NSIS-Installer, which makes installing vvvv just a couple clicks away. :D

Because dependencies are changing often and it was an old project this is only for vvvv_45beta33.7_x86 plus Addonpack and DX11.

It checks&installs DotNet 4.5, DX9, vcredist 2008/2010/2013 and adds a registry entry for AddFlow. After that, you are ready to go (ok, filetype association is missing but we didn't need that)

So, what do you have to do to compile your own installer?

  • Download & Install NSIS
  • Download ZIPDLL-Plugin http://nsis.sourceforge.net/ZipDLL_plug-in , Extract ZipDLL.dll to directory Plugins\x86-ansi in your NSIS installation, Extract ZipDLL.nsh to directory Include in your NSIS installation
  • Download http://nsis.sourceforge.net/DotNetChecker_plug-in and put them in the same directories.
  • Download vvvv_45beta33.7_x86.zip, addons_45beta33.7_x86.zip, vvvv-packs-dx11-1.0.1-x86.zip, vcredist_x86_2008.exe, vcredist_x86_2010.exe, vcredist_x86_2013.exe and put them next to this nsi-script.

In NSIS select the nsi-script provided here.
I'm not shure if we are allowd to upload fully packed installers here, so if anybody interested i can provide them.

One small thing is a little bit annoying: NSIS won't Install to C:\ directly, so vvvv has to be installed in a folder, e.g. C:\vvvv\vvvv_45beta33.7_x86

download

vvvv-installer-x86-dx11.zip - 05.04.17 [15:38 UTC] by avaos | 53 downloads
notes: NSIS-Script for installer

anonymous user login

Shoutbox

~6h ago

u7angel: @xxxlalala i meant matcap, look for that

~8h ago

xxxlalala: thanks @u7angel superphong is exactly what i was looking for. litsphere gave me no search results though :(

~10h ago

u7angel: i guess most pro vvvv users don't use emeshe for various reasons but more custom collection of shaders. see superphong or litsphere

~12h ago

xxxlalala: is emeshe the way to go for rendering with materials ? (asking because it says deprecated)

~3d ago

catweasel: Lovely, that did it! Just needed right click which wasn't coming through :)

~3d ago

catweasel: is the tablet plugin missing from recent builds? seems like all 35v(64bit, or is that the problem?)

~3d ago

joreg: ...aaaand here's the full workshop schedule for #NODE17 node17-workshop-schedule #vvvv

~5d ago

joreg: here we go: complete list of 49 workshops for #NODE17 node17-workshops-announced schedule still to come #vvvv

~5d ago

velcrome: @superflysiNZ it is pretty cool, and works solid. but you need #m4l