» videosync howto?
This site relies heavily on Javascript. You should enable it if you want the full experience. Learn more.

videosync howto?

question open misc legacy

gcarlier 05/03/07 - 02:46

hello,

I'm new to vvvv, and as others users I've read in the forum, I have to sync 4 differents players with differents video of same lenght, for an art exhibition where projectors have to "speak" to each others.
I first think using Midi Timecode to sync between computers, but with a simple patch with a filestream and MTC in, the video drop constantly, any idea how to patch such an installation ?

I've found the videosync module of Tonfilm, but can't figure out how it's work, is the server or the client playing the file ? After setting up the network, the client seems to receive some data, but not starting any player windows.

I've tried to patch a Videout on videosync client, it'doesn't work
Is there any way to find some help about the videosync in documentation ?

Thanks a lot for your help

gc

9 replies 0 new
This is a legacy thread which was closed after one year of inactivity. Information provided in this thread may not be valid for the latest version of vvvv. If you have questions on this topic, you might consider opening a new thread.

link | tonfilm (devvvv) 05/03/2007 - 17:26

first get some info about Boygrouping. then read everything i wrote on the site and inside the patch..

so:
start vvvv as client (/client serverIP in args.txt) on the clients.
start vvvv as server on the the server (/server in args text)
put your files (which must have the same name and length) on the same place on every computer.
start the boygrouping server patch and select the video...

link | gcarlier 05/03/2007 - 18:32

Ok I'm trying right now, thx very much for your help

gc

link | gcarlier 05/03/2007 - 21:59

Hi,

Il followed all instructions about boygrouping and videosync, and I feel that I'm not so far from solution, but I still have a problem. Both server and client seems to communicate well, remote fullscreen works fine, but the directx renderer windows always stay in black.

the path is the same on both computer, and I've tried client and server on two different computers, symptoms are the same, it seems like client don't open the file. When I check the ShowSync box on server, Client show me like a strange draw.

I tried several codecs, same problem.

Any idea ? Thx for your help

gc

link | tonfilm (devvvv) 06/03/2007 - 00:00

if the boygrouping works, i have no idea why it's not working...
just a recheck:

do you start the patch on the clients too? because you must not, only on the server...
do the video files really have exactly the same name on every computer and are at the same location? e.g. c:\video\file.avi
is every computer plying the file correctly in vvvv in a plain patch?
is the video path on the server patch absolute? like c:\video\file.avi, ..\..\file.avi can cause problems...

that are the only things, which still can be worng. i seems that the video file was not found...

link | gcarlier 06/03/2007 - 01:26

great !!!

It's working now, actually it was the path, I left it before in relative, so now it's perfect. Thanks very much for your assistance, your patch is very nice and useful for art installation. The goal of the artwork is to play 4 video source and 1 sound file in 5.1 serving as soundtrack for vids, in a kind of steel octogone, I'll post pictures when job will be finished.

thx.

gc

link | gcarlier 08/03/2007 - 13:53

Hi,

I still have some problems running videosync to achieve my goal, in fact the videos are running out of sync, and not only two frales but sometimes a second. I've searched everywhere the source of the problem, but now I'm out of ideas...

I'm using 3 computers connected on a gigabyte switch, The server is 192.168.0.3, and both clients are .1 and .2
I specified 192.168.100.255 as UDP broadcast Ip on the server.
I cans start and Fullscreen all clients, but they're running out of sync, as if they don't receive the "reclock" signal from udp. I've checked the udp node on the server, and the DoSend is 1, and he's receiving the frame input well.

I've tried different codecs, I presume that the codec is important, as describe in the AV faq, and even with a keyframe every frame I have the same symptoms

Do I forgot something or do soething wrong ??

thx for your help.

gc

ps. I tried to change the audio output in the client, tu put an audio out connected to directshow, using AC3Filter and a digital link cable, outputing a 5.1 AC3 spatialized sound, and it's working very well !!!

link | gcarlier 09/03/2007 - 12:24

No idea for my out of sync problem ?

thx

gc

link | tonfilm (devvvv) 09/03/2007 - 20:10

no, no idea. must be the codec. try to install the ffdshow direct show filters, it will provide mjpg codecs. mjpg was working very well for me...

another thing is the performance, if your computer has problems playing the files smoothly, you can't get a correct sync.

link | tonfilm (devvvv) 20/07/2012 - 17:29

finally, videosync is integreatd in vvvv: video synchronization

anonymous user login

Shoutbox

~6h ago

ventolinmono: Jajaja views column if forum also shows anxiety...

~15h ago

quaddro: nevermind; device(manual) was the solution to map to the right adapter.

~16h ago

quaddro: quick help: trying multiscreen setup with eyefinity 2(spanmode)+1. when trying to go fullscreen vvvv only flashes. any tips?

~18h ago

~1d ago

microdee: 2 new plugins i was working on recently: rod, leap-alternative-nodes

~2d ago

microdee: @mrboni: try the help patches next to the dll

~3d ago

joreg: @apnoe try the Lumax (Devices) node (only in x86 builds)

~3d ago

mrboni: @microdee - just dragged the dll into b32.1

~3d ago

apnoe: anyone some experience with v and ilda / laser controlling? is it possible to send to an usb / ilda interface from v?

~3d ago

fleg: open call still open till friday. international arists are invited to apply! bit.ly/1rRXI1R